Difference between revisions of "ZPUI emulator setup"

From ZeroPhone
Jump to: navigation, search
(Ubuntu/Debian installation)
Line 8: Line 8:
  
 
== Ubuntu/Debian installation ==  
 
== Ubuntu/Debian installation ==  
 +
 +
Assuming Python 2 is the default Python version:
  
 
  <nowiki>
 
  <nowiki>
 
sudo apt-get update
 
sudo apt-get update
sudo apt-get install python2-pip git python2-dev build-essential
+
sudo apt-get install python-pip git python-dev build-essential
 +
sudo pip install luma.emulator
 +
git clone https://github.com/ZeroPhone/pyLCI
 +
cd pyLCI
 +
./setup_emulator.sh
 +
python main.py</nowiki>
 +
 
 +
== OpenSUSE installation ==
 +
 
 +
<nowiki>
 +
sudo zypper install python2-pip git python2-devel gcc python-curses
 
sudo pip2 install luma.emulator
 
sudo pip2 install luma.emulator
 
git clone https://github.com/ZeroPhone/pyLCI
 
git clone https://github.com/ZeroPhone/pyLCI
Line 32: Line 44:
 
== Credits ==
 
== Credits ==
  
Most of the emulator research and work was done by Doug. The input driver was done by Arsenijs.
+
Most of the emulator research and work was done by Doug. The input driver was done by Arsenijs. OpenSUSE instructions were compiled with help of piajesse ([https://hackaday.io/piajesse @Hackaday.io])

Revision as of 10:27, 29 May 2017

If you want to develop pyLCI apps, but don't yet have the ZeroPhone hardware, there's an option to use the emulator - that's going to work with your screen and keyboard, instead of the real ZeroPhone hardware. While some Raspbian-specific apps will not function on other Linux distros (though will load correctly), it's going to work very well for app development. It uses luma.oled library pygame emulation capabilities and a quick custom input device driver that uses pygame input, so separate input hardware (such as a USB keyboard or keypad) is not necessary for emulation, as it was earlier.

System requirements

  • Some kind of Linux - has to have git, python and python-pip
  • Graphical environment - the output uses Pygame
  • Keyboard - used for input (can easily be the same keyboard that's used for the system)

Ubuntu/Debian installation

Assuming Python 2 is the default Python version:

sudo apt-get update
sudo apt-get install python-pip git python-dev build-essential
sudo pip install luma.emulator
git clone https://github.com/ZeroPhone/pyLCI
cd pyLCI
./setup_emulator.sh
python main.py

OpenSUSE installation

sudo zypper install python2-pip git python2-devel gcc python-curses
sudo pip2 install luma.emulator
git clone https://github.com/ZeroPhone/pyLCI
cd pyLCI
./setup_emulator.sh
python2 main.py

In case of problems

You can either:

TODO

  • Help add more installation instructions (have to be verified, though theoretically it should *just work* without apt, using some other package manager)
  • Sometimes the emulator fails to start due to threading problems - there's some problem with pygame screen being refreshed from one thread and input scanned from another. That can't be fixed in current architecture, but the problems seem to only appear on pyLCI startup and typically the problem is solved by starting it again (for me, at least). This is the relevant GH issue that desribes the problem better.

Credits

Most of the emulator research and work was done by Doug. The input driver was done by Arsenijs. OpenSUSE instructions were compiled with help of piajesse (@Hackaday.io)